[TUTORIAL] Getting Started with AndEngine

  ... tutorials on how to use AndEngine.

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby niohoggr » Tue Nov 08, 2011 10:53 pm

RealMayo wrote:And you set the compiler compliance level to 1.6?
You need to do that for EVERY extension.


Yep, I did, and I double checked that.
niohoggr
 
Posts: 15
Joined: Fri Nov 04, 2011 8:16 pm

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby RealMayo » Tue Nov 08, 2011 11:04 pm

niohoggr wrote:one thing I did differently, I have to target 2.1 update 1 instead of 2.2 .
The error says : The import android.opengl.ETC1 cannot be resolved
The import android.opengl.ETC1Util cannot be resolved

So why aren't you targeting Android 2.2 API 8 ?
User avatar
RealMayo
 
Posts: 1681
Joined: Sat Sep 03, 2011 9:25 pm
Location: Chicago, IL

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby niohoggr » Tue Nov 08, 2011 11:12 pm

RealMayo wrote:
niohoggr wrote:one thing I did differently, I have to target 2.1 update 1 instead of 2.2 .
The error says : The import android.opengl.ETC1 cannot be resolved
The import android.opengl.ETC1Util cannot be resolved

So why aren't you targeting Android 2.2 API 8 ?


Because I have on physical device to try it out on and that is a 2.1 update 1 Android OS.
niohoggr
 
Posts: 15
Joined: Fri Nov 04, 2011 8:16 pm

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby RealMayo » Tue Nov 08, 2011 11:17 pm

First you need to try it in the emulator with Android 2.2 API 8.
Does it work in the emulator?
User avatar
RealMayo
 
Posts: 1681
Joined: Sat Sep 03, 2011 9:25 pm
Location: Chicago, IL

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby niohoggr » Tue Nov 08, 2011 11:58 pm

RealMayo wrote:First you need to try it in the emulator with Android 2.2 API 8.
Does it work in the emulator?


It works with if I am not trying to put it in my own project. Only when I try to put the examples in a new project with the 2.1 target did the thing show.
niohoggr
 
Posts: 15
Joined: Fri Nov 04, 2011 8:16 pm

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby RealMayo » Wed Nov 09, 2011 12:05 am

OK well I'm glad everything works for you when you use Android 2.2 API 8.
If you want to use API 7 instead then I suggest you create a new post in the Developer forum to get some help with that. I personally don't think that is possible. Thanks
User avatar
RealMayo
 
Posts: 1681
Joined: Sat Sep 03, 2011 9:25 pm
Location: Chicago, IL

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby niohoggr » Wed Nov 09, 2011 12:09 am

RealMayo wrote:OK well I'm glad everything works for you when you use Android 2.2 API 8.
If you want to use API 7 instead then I suggest you create a new post in the Developer forum to get some help with that. I personally don't think that is possible. Thanks


Ah, ok and thanks for your time and patience. I will post there too, I hope they have a way to work around this problem.
niohoggr
 
Posts: 15
Joined: Fri Nov 04, 2011 8:16 pm

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby METEMEDO » Sat Nov 12, 2011 8:00 am

Just registered (loved the anti-spam thing that asks us the output of System.out.println(Math.sqrt(256)) :lol: ) and got the examples app to work, but only some of them work.

I have a question, i only downloaded the 2.2 sdk thing. If i want my game/applications to work on other versions of android, what should i do? Port it to every other version manually by changing the code?

I'm sorry for the newbish questions, i'm just getting started on android development.
METEMEDO
 
Posts: 6
Joined: Sat Nov 12, 2011 7:54 am

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby RealMayo » Sat Nov 12, 2011 9:36 pm

METEMEDO wrote:I have a question, i only downloaded the 2.2 sdk thing. If i want my game/applications to work on other versions of android, what should i do? Port it to every other version manually by changing the code?

Here check this out...
http://www.andengine.org/forums/development/android-2-1-update-1-and-andengine-is-it-possible-t5641.html
User avatar
RealMayo
 
Posts: 1681
Joined: Sat Sep 03, 2011 9:25 pm
Location: Chicago, IL

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby METEMEDO » Sun Nov 13, 2011 4:02 pm

Yeah but let's say that 2.3 API has a function that 2.2 doesn't.
If i use that function, then it will not work on 2.2.
Should i try to identify the OS version and in case of being 2.3 i use the "native" function and in case of being a lower version i use my own (less efficient) implementation of the function?
METEMEDO
 
Posts: 6
Joined: Sat Nov 12, 2011 7:54 am

PreviousNext

Return to Tutorials

Who is online

Users browsing this forum: Google [Bot], Google Feedfetcher, RonScript and 21 guests