[TUTORIAL] Getting Started with AndEngine

  ... tutorials on how to use AndEngine.

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby Molkobain » Thu Apr 19, 2012 1:40 pm

Hi, thank you for those videos, it helped a lot installing AndEngine and understanding gow to include extensions in a projects. :)
Molkobain
 
Posts: 106
Joined: Wed Apr 18, 2012 4:16 pm
Location: France

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby RealMayo » Thu Apr 19, 2012 2:58 pm

Hi peppewra,
Well that is an easy one... You forgot to set the compiler to 1.6
User avatar
RealMayo
 
Posts: 1683
Joined: Sat Sep 03, 2011 9:25 pm
Location: Chicago, IL

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby peppewra » Thu Apr 19, 2012 4:44 pm

thanks real mayo but this is not the problem. because those messages are the ones gave after setted compiler to 1.6
peppewra
 
Posts: 8
Joined: Tue Apr 17, 2012 8:21 pm

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby RealMayo » Thu Apr 19, 2012 5:03 pm

Ok. Ignoring the examples for a moment, what are the error messages you are getting for AndEngine itself?
User avatar
RealMayo
 
Posts: 1683
Joined: Sat Sep 03, 2011 9:25 pm
Location: Chicago, IL

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby peppewra » Thu Apr 19, 2012 8:07 pm

in package andEngine the only error i have is in class Polygon for EarClippingTriangulator, it says cannot be resolved to a type. before you ask yes, i downloaded even all the expansion, i checked manually and i have that class
peppewra
 
Posts: 8
Joined: Tue Apr 17, 2012 8:21 pm

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby peppewra » Thu Apr 19, 2012 8:22 pm

maybe i found the solution to everything. i have to add to the build path the package of the engine for the examples and the package of phisics for the error in the engine.

confirm me if it is right
peppewra
 
Posts: 8
Joined: Tue Apr 17, 2012 8:21 pm

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby peppewra » Fri Apr 20, 2012 10:12 am

obviously doesn't work
peppewra
 
Posts: 8
Joined: Tue Apr 17, 2012 8:21 pm

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby OzLark » Sat Apr 21, 2012 5:06 am

peppewra wrote:obviously doesn't work


Does this help: gles2/polygon-primitive-t6217-40.html#p31644
Did this post help you? Feel free to return the gesture by downloading Ninja Bees, creating a level (or more) and sharing it to the Ninja Bees website!

Ninja Bees - Our latest Android game, check it out on Google Play (free) or paid with no ads
OzLark
 
Posts: 1130
Joined: Sun Feb 05, 2012 3:19 am

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby michealbach » Mon Apr 23, 2012 6:51 pm

Hey everyone, I hate to bug you guys about my inability to get GLES2 working, but I'm all kinds of stuck on this one error. If anyone could please take a look and give me some suggestions on fixing - I would greatly appreciate it.

I'm trying to do a project that is copy/pasted from SpriteExample.

Here is the error:

04-23 10:37:37.745: E/AndroidRuntime(8348): java.lang.RuntimeException: Unable to instantiate activity ComponentInfo{com.micheal.gles2project/com.micheal.gles2project.GLES2ProjectActivity}: java.lang.ClassNotFoundException: com.micheal.gles2project.GLES2ProjectActivity in loader dalvik.system.PathClassLoader[/data/app/com.micheal.gles2project-2.apk]


Here is my manifest:

Syntax: [ Download ] [ Hide ]
Using java Syntax Highlighting
  1. <?xml version="1.0" encoding="utf-8"?>
  2. <manifest xmlns:android="http://schemas.android.com/apk/res/android"
  3.     package="com.micheal.gles2project"
  4.     android:versionCode="1"
  5.     android:versionName="1.0" >
  6.  
  7.     <uses-sdk android:minSdkVersion="8" android:targetSdkVersion="8"/>
  8.  
  9.     <uses-feature android:glEsVersion="0x00020000" android:required="true"/>
  10.         <uses-feature android:name="android.hardware.touchscreen" android:required="false"/>
  11.  
  12.         <application android:icon="@drawable/ic_launcher" android:label="@string/app_name">
  13.                 <activity android:name="com.micheal.gles2project.GLES2ProjectActivity" android:label="@string/app_name">
  14.                         <intent-filter>
  15.                                 <action android:name="android.intent.action.MAIN"/>
  16.                                 <category android:name="android.intent.category.LAUNCHER"/>
  17.                         </intent-filter>
  18.                 </activity>
  19.         </application>
  20. </manifest>
Parsed in 0.034 seconds, using GeSHi 1.0.8.4


I have the AndEngine linked to my project via the Properties -> Java Build Path -> Projects -> AndEngine

Note that whenever I run as Android Application, I get the error on the console:
[2012-04-23 10:47:15 - AndEngine] Could not find AndEngine.apk!
[2012-04-23 10:47:15 - GLES2Project] Starting activity com.micheal.gles2project.GLES2ProjectActivity on device SH0CBR203457
[2012-04-23 10:47:16 - GLES2Project] ActivityManager: Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=com.micheal.gles2project/.GLES2ProjectActivity }



Where do I go from here? I'm very stuck. Thanks in advance.
User avatar
michealbach
 
Posts: 47
Joined: Wed Feb 02, 2011 11:16 pm
Location: Greeley, CO

Re: [TUTORIAL] UPDATED - Getting Started with AndEngine

Postby Molkobain » Tue Apr 24, 2012 9:21 am

Hi Michael,

what if you link AndEngine as a library and note a project ?
- Remove AndEngine from Properties > Java Build Path > Projects.
- Go to Properties > Android > Library > click Add.
- Choose the AndEngine project, click OK. It should have a green tick on the left.

The way I understand it, from GLES2 AndEngine must be add as an Android library.
Molkobain
 
Posts: 106
Joined: Wed Apr 18, 2012 4:16 pm
Location: France

PreviousNext

Return to Tutorials

Who is online

Users browsing this forum: M26 and 28 guests