Slow?

  ... in the unlikely case you discovered a bug, post it here.

Slow?

Postby pd » Thu Dec 29, 2011 1:55 am

Managed to compile my project with this new version and it is much slower than previous version, I am getting much lower fps, also I can not see any particles using SpriteParticleSystem. My device is HTC Desire.
pd
 
Posts: 15
Joined: Thu Jul 28, 2011 11:13 am

Re: Slow?

Postby nazgee » Mon Jan 23, 2012 4:09 pm

Topic of this thread is a little bit fuzzy, so I'll ad something here.

Particle system is dreadfully slow - some more details are here:
gles2/gles2-vs-gles1-overral-performance-decreased-t6479.html

But generally: I have ALL examples up and running fine. Particles examples are working too, BUT they are freaking slow. I am using HTC Desire too- maybe this is device-specific issue?
Dirt Rider Mayhem is PUBLISHED now!
Image
User avatar
nazgee
 
Posts: 524
Joined: Fri Oct 21, 2011 10:31 pm
Location: Poland, Wrocław

Re: Slow?

Postby m01 » Thu Jan 26, 2012 10:56 pm

I noticed a performance drop, too... and I'm also using particle systems - HTC desire Z.
(Haven't done any specific FPS measurements yet though)
m01
 
Posts: 5
Joined: Thu Jan 19, 2012 11:28 pm

Re: Slow?

Postby connexion2000 » Fri Feb 24, 2012 8:31 am

I also got massive performance drop with nexus example. I can confirm it on xperia arc and asus transformer.
connexion2000
 
Posts: 1
Joined: Fri Feb 24, 2012 8:29 am

Re: Slow?

Postby tam7t » Thu Mar 01, 2012 3:40 am

The arguments for AlphaParticleModifier<Sprite> were rearranged from the version of AndEngine GLES1 that i was using to GLES2. Check again that you have the arguements in the correct order:

pFromTime, pToTime, pFromAlpha, pToAlpha
tam7t
 
Posts: 3
Joined: Thu Mar 01, 2012 3:35 am

Re: Slow?

Postby OzLark » Tue Mar 27, 2012 11:14 am

I've also got this issue too, adding two very simple SpriteParticleSystem objects to my scene eats 20 - 35 frames a second...

I too am using a HTC Desire.

This is obviously useless - is this the same on all devices? just the Desire? any solutions?
Did this post help you? Feel free to return the gesture by downloading Ninja Bees, creating a level (or more) and sharing it to the Ninja Bees website!

Ninja Bees - Our latest Android game, check it out on Google Play (free) or paid with no ads
OzLark
 
Posts: 1130
Joined: Sun Feb 05, 2012 3:19 am

Re: Slow?

Postby badchoice » Tue Apr 03, 2012 4:08 pm

Is there any solution on this?
badchoice
 
Posts: 91
Joined: Wed Apr 06, 2011 9:23 am
Location: Barcelona


Return to Bugs

Who is online

Users browsing this forum: No registered users and 2 guests