Concurrent touches not being detected

  ... in the unlikely case you discovered a bug, post it here.

Concurrent touches not being detected

Postby Draiken » Mon Mar 24, 2014 7:51 pm

I have pretty much the same controls on the race example of the engine. A AnalogOnScreenControl and a Button.

The problem is, when I'm using the analog directional, touching the button does not trigger onAreaTouched on the button sprite.

I even tried adding the button to the child scene (controller scene) but it doesn't register the secondary touch on the button.

Am I doing something wrong or is this a bug?

Thanks!
Draiken
 
Posts: 4
Joined: Sun Aug 26, 2012 4:48 am

Re: Concurrent touches not being detected

Postby Draiken » Tue Mar 25, 2014 2:12 pm

I am doing some debugging and apparently if I touch the control base, it triggers it's onAreaTouched, but if I keep touching it, and then touch the button (on the other side of the screen) the same onAreaTouched from the control base is the only one receiving the touch event.

I really can't understand why this is happening.
Draiken
 
Posts: 4
Joined: Sun Aug 26, 2012 4:48 am

Re: Concurrent touches not being detected

Postby Draiken » Tue Mar 25, 2014 5:43 pm

Guess I'm just stupid and didn't see the multiple controls example that activates the EngineOptions necessary for multi touch support.

Sorry for the stupid post.
Draiken
 
Posts: 4
Joined: Sun Aug 26, 2012 4:48 am


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest